come aggiornare bene debian con apt e la sources.list?

salve a tutti,
sono passato da poco a Debian, mi piace molto, ma ho qualche problema ora con amule.
ho inserito nel file /etc/apt/sources.list
le righe:

## AMule
deb http://www.vollstreckernet.de/debian/ testing amule
deb http://www.vollstreckernet.de/debian/

ma ora quando cerco di installarlo
apt-get update
apt-get install amule

mi escono i seguenti errori:

amule:
Dipende: libc6 (>=2.3.5-1) ma 2.3.2.ds1-22 verrà installato
Dipende: libgcc1 (>=1:4.0.1) ma 1:3.4.3-13 verrà installato
Dipende: libstdc++6 ma non sta per essere installato
Dipende: libwxgtk2.6-0 ma non sta per essere installato

ciò, mi sembra di capire, è dovuto alle vecchie librerie che ho installate.
quali sono le righe che dovrei inserire nel sources.list per aggiornare tutto?
ora il mio sources.list è completamente vuoto...
grazie mille
rat-man

Commenti

ciao, io ho mepis che si

ciao,
io ho mepis che si basa debian, verifica che i repository esistano ancora, magari aggiorna le source.list mi pare ci siano state molte modifiche, almeno per la mepis e siccome mepis fa uso di repository debian...
prova da synaptic il tool grafico per installare gli aggiornamenti, disinstalla e poi reinstalla amule
ciao